Topic: waiting for time of use not working - SOLVED via static IP address

Hi there,

So I had an issue with my Pro 40 EVSE for about three days and could not figure out how to solve it until  this morning when I tried something seemingly unrelated.  The EVSE is supposed to blink orange slowly when you enable time of use through the web application.  However the last three days, the EVSE would charge prematurely (solid orange) when I plugged in early, and the web application would indicate "Charging - Waiting for Time of Use" which is a very confusing message.  I noticed that my blue light was blinking slowly.  This was confusing as well, as I figured that if the EVSE could not connect to my LAN properly, I would not be able to see any status updates of the EVSE on the web application.

After several failed attempts at unplugging the EVSE, and connecting to LAN, I finally tried something different.  I clicked on the Advanced button when finding an SSID, and assigned a static IP address to the EVSE.  This time around I received a solid blue light.  Now the functionality of the blinking orange light is restored.

I thought this bit of info could be useful to anyone who suddenly lost the time of use functionality.  It was really baffling as I didn't configure anything differently on my LAN for over a year, and the time of use functionality was working the whole time.


Re: waiting for time of use not working - SOLVED via static IP address

This is just a short note to let you know that this is a support forum for the Juicebox-Pro web gallery software from SimpleViewer Inc.

From your post above, it sounds like you are referring to a 'JuiceBox' from eMotorWerks, a completely unrelated company to our own (although the product names are the same).

I do not know if they have a forum but anyone who needs to contact eMotorWerks directly for support should be able to do so via their online form here: