1 (edited by steve zee 2020-07-06 21:54:14)

Topic: very first publish fails on simple test page !!

I saved my html in a folder of my choosing, not the default, and then this:

why cant I post TWO screen shots?

mac osx10.15.5
brand new juice box
firefox

why does my screen shot disappear?> Now i've added it for the 3d time.

Re: very first publish fails on simple test page !!

If you are seeing the "Config file not found." message when previewing a gallery locally (from your computer's hard drive), then please see this forum post for a possible solution.

If you are seeing the "Config file not found." message when viewing a gallery online (from a web server), then please see this FAQ: When I view my gallery I see the message 'Config file not found'. How do I fix this?

If the information contained in the links above does not help, then please post back to let me know and I'll try to help further.
If your gallery is online, then please also post a link to the gallery so that I can see the problem for myself.
If your gallery is not yet online, then please zip the gallery folder, upload the zip file and provide a link so that I can download the gallery and take a look.
Thank you.

why does my screen shot disappear?

I'm not sure. I've just checked and attaching an image to a post works OK for me.
After clicking 'Browse' and selecting an image, be sure to click the 'Add file' button to actually add the image to the post.
I hope this helps.

Re: very first publish fails on simple test page !!

Ok that worked thank you.  Are we supposed to know such things?

4 (edited by steve zee 2020-07-07 20:31:48)

Re: very first publish fails on simple test page !!

So today I dont see anything to open from my first test yesterday.

Post's attachments

Screen Shot 2020-07-07 at 2.26.27 PM.png
Screen Shot 2020-07-07 at 2.26.27 PM.png 31.19 kb, 3 downloads since 2020-07-07 

You don't have the permssions to download the attachments of this post.

Re: very first publish fails on simple test page !!

I'm glad to hear that you have ben able to resolve your original problem. Thank you for letting me know.

When opening a gallery in JuiceboxBuilder, there is no special project file to look for.
Just navigate towards and select the gallery folder itself (in your case the 'publish' folder), not a file within the gallery folder.
The gallery folder must contain the gallery's configuration file which must be named 'config.xml' (this is what JuiceboxBuilder-Pro looks for and uses to open the gallery).
Incidentally, if you have changed the structure of your gallery since saving it (and use a configUrl or baseUrl to rename or move the configuration file), then JuiceboxBuidler-Pro will not be able to open the gallery.
However, as your gallery has a regular structure and your gallery's configuration file has not been renamed, you should be able to open your gallery as follows:

Instructions to open an existing gallery in JuiceboxBuilder (to edit it):

(1) Click the 'Open Gallery...' button on the 'Start' tab (or select 'Gallery -> Open...' from the drop-down menu at the top of the application).

(2) In the pop-up 'Select Gallery Folder...' dialog window:
Mac - Navigate towards and then double-click the gallery folder.
Windows - Navigate towards and then select (with a single left-click) the gallery folder (not a file within the gallery folder) and click the 'Select Folder' button.

Re: very first publish fails on simple test page !!

OK that worked thanks.  feeling stupid...

Re: very first publish fails on simple test page !!

No worries! I'm glad you've got things working.

Re: very first publish fails on simple test page !!

Great, now this.
Word Press has completely changed since I last uploaded any simpleviewer show.
Do you have any idea per chance how to put up a juicebox show?
Thanks
I know that's not your responsibility, but it must be simple?

Re: very first publish fails on simple test page !!

You could either:
(1) Use WP-Juicebox (the dedicated Juicebox plugin for WordPress).
... or:
(2) Embed a Juicebox gallery (created with JuiceboxBuilder-Pro on your computer) manually into a WordPress page or post using the baseUrl method documented here.

(1) WP-Juicebox
You can download WP-Juicebox from its own support page here.
Instructions for use can be found on the same web page.
Just follow the first four steps in the 'Adding a Gallery' section and then scroll down to 'Adding Images From WordPress Media Library -> WordPress 5.0 (Gutenberg Editor)' for instructions on how to add images to your gallery (by attaching images to the page or post).

(2) Manual Embed
Here's an example of how to embed a gallery (created with JuiceboxBuilder-Pro on your computer) manually into a WordPress page or post.

Step #1
Create your gallery with JuiceboxBuilder-Pro and save it to a new empty folder named "my_gallery_folder".

Step#2
Upload the entire gallery folder (not just the contents) to the root directory of your web server (using an FTP program such as Filezilla).

Step #3
Create a new 'Custom HTML' Gutenberg block (in the 'Formatting' section) and paste the following embedding code (changing the gallery dimensions and background color if you like):

<!--START JUICEBOX EMBED-->
<script src="/my_gallery_folder/jbcore/juicebox.js"></script>
<script>
    new juicebox({
        baseUrl: "/my_gallery_folder/",
        containerId: "juicebox-container",
        galleryWidth: "100%",
        galleryHeight: "600",
        backgroundColor: "#222222"
    });
</script>
<div id="juicebox-container"></div>
<!--END JUICEBOX EMBED-->

The leading slashes in the paths above denote your root directory so the code above will work without modification as long as your gallery folder is named "my_gallery_folder" and has been uploaded to your root directory.

Incidentally, you can upload your gallery folder to anywhere on your web server as long as the two paths within the embedding code (the path to the 'juicebox.js' file and the baseUrl entry itself, pointing towards the gallery folder) are correct.

I hope this helps.

Re: very first publish fails on simple test page !!

Very nice thank you
above and beyond the call of duty !!
It's up to me now (eek).

11 (edited by steve zee 2020-07-09 21:30:27)

Re: very first publish fails on simple test page !!

OK lots of stuff here:
well i see so many instructions for so many conditions. 
I uploaded the juicebox show I made to my web host exactly where it belongs and I just want to have my word press site show it.
Instead i get CREATE GALLERY; well no, i already created it. Or load images, but that does
not load all the pieces and parts, and load them from where?  The juicebox folderon site now?  I dont want to reload them from
home into the media library when the whole folder is now at my web host.  Or stick the embed code into what?  That
code knows where my uploaded juicebox show is?    Sorry, but I'm just so far behind modern webbing.

here is another thing.  When I see my juicebox gallery online in a dinky crappy little device, the full frame version expands nicely with touch, to read the small print, but we cant get to the next page without going BACK!  When I use the thumbnail tab, i can swipe next to next, but cannot enlarge to read the type.   

No option to add image unless I preview.
I'm logged in but this wont post saying I'm NOT.
OK I add the file in preview and then i dont see anything.

Re: very first publish fails on simple test page !!

It's an either/or situation...

If you choose to manually embed a gallery, then you do not need to use/install WP-Juicebox at all and there is no need to use the WordPress Media Library to add images to the post.

Just follow the 3 steps in the Manual Embed instructions above exactly (nothing more, nothing less) and your gallery should display in your web page.
(Upload the complete gallery folder to your root directory and paste the embedding code into a Gutenberg 'Custom HTML' block.)

That code knows where my uploaded juicebox show is?

Yes. The first path in the embedding code points towards the 'juicebox.js' JavaScript file (inside the gallery's 'jbcore' folder) and the baseUrl entry points towards the gallery folder.
As I mentioned in the example from my previous email, as long as you name your gallery folder "my_gallery_folder", upload the complete gallery folder to your root directory and use the embedding code exactly as I posted it, everything should work fine.
You can change the name or location of your gallery folder on your web server if you like but, if you do, then you'll need to make sure that the two paths in the embedding code are adjusted accordingly.

If you do choose to use WP-Juicebox, then you'll need to create your gallery using the plugin and use the WordPress Media Library to add images to the post. (When you open the media window to add your images, you'll likely see a 'Create Gallery' button. This refers to creating a native WordPress gallery (it has nothing to do with WP-Juicebox) which you don't want to do. All you want to do is attach images to the post so, after uploading the images, just close the media window (do not press the 'Create Gallery' button).

but we cant get to the next page without going BACK!

On a mobile device, you should be able to swipe left and right to navigate through the images.
What device and browser (and version numbers) are you seeing the problem on?
Please post the link to your gallery so that I can try it for myself.

No option to add image unless I preview.

I'm not seeing any problem with the forum software at the moment (and I log in multiple times each day).
The option to add an attachment appears for me without the need to preview.
Try completely clearing your browser's cache (or try a different browser) in case this helps.
I remember once (a long time ago now), not being able to reach the 'Register' page in the forum and clearing my browser's cache helped me to resolve that problem so it's certainly something worth trying.

Re: very first publish fails on simple test page !!

"On a mobile device, you should be able to swipe left and right to navigate through the images.
What device and browser (and version numbers) are you seeing the problem on?
Please post the link to your gallery so that I can try it for myself."

iphone 6   ios 12.4.6
cant tell what safari version #

if I hide the thumb nails, I can swipe the pages but I cant spread the page larger to read the type,
OR
If I open image in a new window I can enlarge the page but not swipe.
both require going back to change those 2 settings every time.
If I do nothing, the feature pictures are just too tiny to view, competing with the thumbnails.
THANK YOU

https://www.stevezavodny.com/blog/galle … index.html

Re: very first publish fails on simple test page !!

Thank you for the additional information and the link to your gallery.
I hope that my notes below help to clarify some things.

I cant spread the page larger to read the type

Unfortunately, it can be very difficult to pinch-zoom within a Juicebox gallery as a pinch-zoom gesture can often be misinterpreted as the start of a navigation swipe within the gallery so, for a full-page or expanded gallery, Juicebox locks the viewport of the web page (preventing pinch-zooming) to avoid such issues.
There is no easy solution to make Juicebox gallery images easily zoom-able. (Juicebox does not have any built-in zoom functionality.)

If you'd like to zoom into an image, then the best course of action (as you have already discovered) is to open the image on a page of its own first via the gallery's 'Open Image' button (by setting showOpenButton="TRUE" in JuiceboxBuilder-Pro's 'Customize -> Lite' section) or by tapping/clicking the main image (when setting imageClickMode="OPEN_URL" in the 'Customize -> Main Image' section).
Once the image is displayed on a page of its own, it can be zoomed with ease (and without adversely affecting the gallery itself).
Of course, afterwards, you need to use the browser's own back button (or tab/window selection tool) to return to the gallery page (as noted below).

If I open image in a new window I can enlarge the page but not swipe.

If you click the 'Open Image' button, then you are no longer within the gallery and are simply viewing the chosen image in isolation (i.e. the browser is displaying the image on its own).

If I do nothing, the feature pictures are just too tiny to view, competing with the thumbnails.

I notice that your gallery sets screenMode="LARGE", forcing the gallery to be displayed in Large Screen Mode (where thumbnails and main images share the gallery area) on all devices and in all browsers.
If you set screenMode="AUTO" (the default value for this configuration option in JuiceboxBuilder-Pro's 'Customize -> General' section), then the gallery will be displayed in Small Screen Mode when viewed on mobile devices (and Large Screen Mode when viewed in desktop browsers).
In Small Screen Mode, thumbnails and main images are displayed on separate pages (giving the main images more space).

Also, if a gallery is embedded in a web page alongside other content and displayed in Small Screen Mode, then Juicebox will initially display the Splash Page. I mention this as you'll see the Splash Page if you set screenMode="AUTO", embed your gallery into a WordPress page and view your gallery on a mobile device.

The Splash Page is a placeholder for the gallery which is displayed by default on mobile devices when the gallery is embedded in a page alongside other content (rather than displayed on a page of its own with dimensions of 100% x 100%, filling the browser window) and may may too small to be usable.

The Splash Page is essentially an image link for the gallery which displays an image (by default, the first image in the gallery) and some text.
When the user clicks or taps the Splash Page, the gallery is expanded to fill the browser window (giving the images more space to be displayed).

For more information about Screen Modes, the Splash Page and how Juicebox adapts to different devices and screen sizes, please see here.
A sample gallery using the Splash Page can be found here.

You can choose to not use the Splash Page by setting showSplashPage="NEVER" (in JuiceboxBuilder-Pro's 'Customize -> Splash Page' section) or to always use the Splash Page (on all devices and in all browsers) by setting showSplashPage="ALWAYS". Leaving showSplashPage="AUTO" (its default value) works well for most scenarios, though.

If you chose to use the Splash Page for Small Screen Mode (on mobile devices), you can customize it (for example to change the Splash Page image or the text displayed on the Splash Page) using the Splash Page configuration options.

Re: very first publish fails on simple test page !!

thank you I'll try again to be on my own

Re: very first publish fails on simple test page !!

You're welcome! I hope you get on OK.
Just let me know if you run into any difficulties and I'll do my best to help you out.

17 (edited by steve zee 2020-08-05 21:51:14)

Re: very first publish fails on simple test page !!

aaieeee why is this so difficult?


Reorder the images (if necessary) by going to the 'Create Gallery -> Media Library' section, selecting 'Uploaded to this post' from the drop-down menu and then dragging and dropping the images into the order you require.

NONE of this is one my word press page (5.4 I am betting; it doesnt tell us anywhere what version) .
I found a way to move them around.  Each picture has a pair of arrows to move the picture around.

Close the media window using the cross at the top right (do not click 'Create a new gallery').

There is no cross, see photo.
AGAIN there is nothing on this support page to add a photo. There is on
the preview page, but the photo just disappears.  then I have to go to a "pun page"?
Then that just publishes this post with no photo at all.  etc.
Never seen such a convoluted attachment process that does not even work.


You can now safely remove the 'Gallery' block from the post. (Using a 'Gallery' block is just a convenient method of attaching images to a post.

)

How on earth are we supposed to remove the block??
OK I found that at the very bottom of "hidden".
tried a preview here and Preview post jumbled up the photo order too.
Now I want to edit the juicebox gallery, but no:

Select the 'Manage Galleries' link from the 'WP-Juicebox' menu in the left column of WordPress.

Nope, nothing like this at all anywhere.  see photo, oh wait, cant show photos. 
All I get is the shortcode page with NOTHING else on it and therefore no left column.
Preview post jumbled up the photo order too.  But at least something IS there.

Modify your gallery options in the 'Edit Gallery' screen

I hope this gives us the traditional at-home editing juicebox interface we are used to
when we build sites here on the computer at home?


and why on earth is word press so different now?   Used to just see and do everything
right in front of our eyes.  No hidden galleries, no hidden tools, no hidden type, etc



please and thanks !

Re: very first publish fails on simple test page !!

and why on earth is word press so different now?

That's something that you'd need to ask in the WordPress forum. The Gutenberg Editor is certainly a complete departure from the old familiar Classic Editor.

The instructions on the WP-Juicebox support page are quite accurate and if you don't see any of the buttons mentioned in the instructions, then your WordPress installation may be the root of the problem. Perhaps you have a third-party plugin which is either changing core WordPress functionality or interfering with WP-Juicebox (or both).

Maybe the best way to proceed would be to continue using WordPress 5.4.2 (keeping WordPress up-to-date for security reasons) but revert to the Classic Editor (rather than the Gutenberg Editor).
The Classic Editor is no longer bundled with WordPress but you can download it as a plugin from here.
Once you install and activate the Classic Editor, things should look and function exactly as they did before the Gutenberg editor was introduced.

Also, I'll try to answer some of the queries from your last email in case they help with certain issues.

(5.4 I am betting; it doesnt tell us anywhere what version) .

On your WordPress dashboard page, scroll down and the version number should be displayed in the lower-right corner of the screen.

Close the media window using the cross at the top right (do not click 'Create a new gallery').

There is no cross, see photo.
AGAIN there is nothing on this support page to add a photo. There is on
the preview page, but the photo just disappears.  then I have to go to a "pun page"?
Then that just publishes this post with no photo at all.  etc.
Never seen such a convoluted attachment process that does not even work.

I think we're at cross purposes here...
When I refer to closing the media window, I am referring to WordPress's media window.
However, your response seems to be referring to attaching an image to a post here in the forum (the forum is PunBB).

How on earth are we supposed to remove the block??

I realise that you have discovered how to remove a Gutenberg block but this link might help others with the same problem.

Nope, nothing like this at all anywhere.

The lack of a 'WP-Juicebox' menu link in the left column of the WordPress dashboard suggests that the WP-Juicebox plugin may not be installed and active within your WordPress instalation. (It should be very close to the bottom of the list, just above 'Collapse menu'.)
You should be able to access the 'WP-Juicebox -> Manage Galleries' page as shown in the screenshot attached.

I hope this gives us the traditional at-home editing juicebox interface we are used to
when we build sites here on the computer at home?

It gives the same interface that WP-Juicebox has always had (for many years).

I think reverting to the Classic Editor should help.
WP-Juicebox has not changed much over the years at all.
However, Wordpress has changed significantly.
WP-Juicebox simply displays images attached to a post but attaching images to a post is core WordPress functionality and the method of attaching images to a post will differ depending on what version of WordPress you are using. (Different versions of WordPress are accounted for in the WP-Juicebox instructions.)

I hope that using the Classic editor helps to resolve your problems.

Post's attachments

Capture.png
Capture.png 39.6 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

Re: very first publish fails on simple test page !!

Thank you !

yes the plug in is active.  That's why I got in trouble further down the production line.
I wish I could show you the screen shot of where all these problems started
and why stuff seems missing.

Anyway, I wonder how long I'll be able to use "WP Classic" and wouldn't I just
wind up right here again?

Ok, now here I am with the option to "submit" or "preview".
No options for uploads.  I'll hit "preview".

OK, here in preview the attachments feature exists.
I'll "add file" and see what happens.
OK I got this:
"Warning! The following errors must be corrected before your message can be posted:
You did not select a file for upload."

ok, lets "browse" first.  Voila!  There it is.  This was showing that there is nothing in the upper right corner to click.  You can see there is nothing on the left to navigate to juicebox plug in.  You cannot even see there are photos associated with this editing page, yet when published, there actually IS a photo page.  It's all wrong tho, why I wanted to make it right with your plug in.

Post's attachments

Screen Shot 2020-08-08 at 3.28.07 PM.png
Screen Shot 2020-08-08 at 3.28.07 PM.png 64.44 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

Re: very first publish fails on simple test page !!

Anyway, I wonder how long I'll be able to use "WP Classic" and wouldn't I just
wind up right here again?

Yes, I agree. It would be better to get to grips with WordPress 5 and new Gutenberg Editor as this seems to be the way forward and WordPress are not going to drop the Gutenberg Editor any time soon.

Your screenshot shows that WP-Juicebox is installed and active and that you've managed to add a Juicebox gallery to your post.
All you need to do now is attach images to your post (using core WordPress functionality) and Juicebox will automatically display them in the gallery.

(1) Click the 'Add Block' button (the '+' in a circle near top-left in your screenshot) to add a new Gutenberg block to your page or post.
(2) Select a 'Gallery' block. (You'll find it in the 'Common Blocks' section.)
(3) Click the 'Media Library' button within the 'Gallery' block.
(4) Drag and drop the images that you want to attach to your page or post (i.e. the images that you would like to be displayed in your WP-Juicebox gallery) from your hard drive into the media window.
(5) Wait until the images have finished uploading.
(6) Reorder the images (if necessary) by going to the 'Create Gallery -> Media Library' section (within the media window), selecting 'Uploaded to this post' from the drop-down menu and then dragging and dropping the thumbnails into the order you require.
(7) Close the media window via the cross at the top right. (Do not click the 'Create a new gallery' as this will create a native WordPress gallery in addition to your WP-Juicebox gallery.)
(8) You can now safely remove the 'Gallery' block from the post. (Using a 'Gallery' block is just a convenient method of attaching images to a post.)

WordPress does not make it easy to attach images to a post (or to see images which are attached to a post) but the above method works.

If you find you still have trouble attaching images to a post, then there are a couple of alternatives.

(1) You could use a Flickr account as the source of images for your Juicebox gallery. WordPress would then have no part in the image management of your gallery.

(2) You could choose not to use WP-Juicebox at all and, instead, create a Juicebox gallery on your computer (with JuiceboxBuilder) and manually embed the gallery into your WordPress post using the baseUrl method documented here. Here is an example of how you could do this:

Step #1
Create your gallery with JuiceboxBuilder and save it to a new empty folder named "my_gallery_folder".

Step#2
Upload the entire gallery folder (not just the contents) to the root directory of your web server (using an FTP program such as Filezilla).

Step #3
Create a new 'Custom HTML' Gutenberg block (in the 'Formatting' section) and paste the following embedding code (changing the gallery dimensions and background color if you like):

<!--START JUICEBOX EMBED-->
<script src="/my_gallery_folder/jbcore/juicebox.js"></script>
<script>
    new juicebox({
        baseUrl: "/my_gallery_folder/",
        containerId: "juicebox-container",
        galleryWidth: "100%",
        galleryHeight: "600",
        backgroundColor: "#222222"
    });
</script>
<div id="juicebox-container"></div>
<!--END JUICEBOX EMBED-->

The leading slashes in the paths above denote your root directory so the code above will work without modification as long as your gallery folder is named "my_gallery_folder" and has been uploaded to your root directory.

Incidentally, you can upload your gallery folder to anywhere on your web server as long as the two paths within the baseUrl embedding code (the path to the 'juicebox.js' file and the baseUrl entry itself, pointing towards the gallery folder) are correct.

You can see there is nothing on the left to navigate to juicebox plug in.

You'll only see the 'WP-Juicebox -> Manage Galleries' link (shown in my screenshot in a post above) on your WordPress dashboard page (not on an 'edit a post' page such as the one shown in your most recent screenshot).
Just click the 'W' icon (the one in the circle at the top-left of your screenshot) to see the WordPress dashboard menu ath teh left of your screen. The WP-Juicebox link will be near the bottom of the list. (This will not help you to attach images to a post, though... it will only give you access to the 'Manage Galleries' page where you can edit galleries (to change configuration options) or delete galleries.)

You cannot even see there are photos associated with this editing page, yet when published, there actually IS a photo page.

That's down to the way WordPress works. The only way I've found to see the images attached to a post (whilst creating or editing a post) is to create a 'Gallery' block, check the images in the media window (accessed via the 'Gallery' block') and then remove the 'Gallery' block afterwards.
Otherwise, you can see which images are attached to which posts in the 'Media -> Library' itself (accessed via the WordPress dashboard).

I hope my notes above help somewhat.

Re: very first publish fails on simple test page !!

I did all those things and actually managed to get a real life page,
but the photos and thumbnails changed order when posted.
I went to "manage galleries>edit jb gallery id=1" and I cant
manage the pictures and the thumbnails and everything else ? 
I.E. cannot EDIT.  I'm going to have to do it all over again from
the start using an alternate method above?

Re: very first publish fails on simple test page !!

Editing a gallery on the 'WP-Juicebox -> Manage Galleries' page will allow you to change the gallery's configuration options.

When using the WordPress Media Library as a source of images for your gallery, all image handling (including the order of the images) is done using core WordPress functionality.

When first uploading a batch of images for a gallery, the initial image order will be the order in which the images finish uploading.

If you want to reorder images in a gallery after the gallery has been created...

(1) Edit the post containing the gallery.

(2) Add a Gutenberg 'Gallery' block to the post. (This is just a temporary method of accessing the images attached to the post.)

(3) Click the 'Media Library' button (within the 'Gallery' block) to access the media window.

(4) Make sure that 'Create gallery' is the selected option (in the left side menu of the media window).

(5) Make sure that 'Media Library' is the selected tab (at the top of the media window).

(6) In the 'Filter media' drop-down menu, select 'Uploaded to this post'. All images attached to the post will be displayed as thumbnails.

(7) Drag and drop the thumbnails into the order that you'd like them to be displayed in the gallery.

(8) Close the media window (via the cross at the top right).

(9) Remove the 'Gallery' block from the post. (It is no longer required.)

There is no need to re-publish the post. The images will have been reordered internally by WordPress as soon as the Drag and drop action is finished.

If the images look to be in the correct order but are not, then just drag and drop an image out of place and then drag and drop it back into place. This will force WordPress to reorder the images internally.

23 (edited by steve zee 2020-08-27 18:53:48)

Re: very first publish fails on simple test page !!

ok this worked, altho I never see the familiar juicebox editing interface.
For example, what if I wanted to move the thumbnails to the left, vertical,
or change their size?  In the screen shot, how do I get the unwanted labels
off the pictures off?  Thanks !!

Post's attachments

Screen Shot 2020-08-27 at 12.46.09 PM.jpg
Screen Shot 2020-08-27 at 12.46.09 PM.jpg 70.78 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

Re: very first publish fails on simple test page !!

... I never see the familiar juicebox editing interface.

WP-Juicebox has individual interface controls for Lite options only.
Pro options must be entered in the 'Pro Options' text area of the gallery settings window, one per line, such as:

expandInNewPage="TRUE"
showImageOverlay="ALWAYS"

This has always been the case with WP-Juicebox (and setting Pro Options in a WP-Juicebox gallery is noted in the WP-Juicebox support page here).

You will find the 'Pro Options' text area in the gallery settings window when you first create a gallery.
You can access the gallery settings window for a pre-existing gallery by going to 'WP-Juicebox -> Manage Galleries' (from the WordPress Dashboard side menu) and clicking 'Edit' next to the gallery that you'd like to modify.

...what if I wanted to move the thumbnails to the left, vertical,
or change their size?

Try adding something like the following to a gallery's 'Pro Options' text area, changing the values as necessary:

thumbWidth="75"
thumbHeight="75"
thumbsPosition="LEFT"
maxThumbRows="10"
maxThumbColumbs="3"

In the screen shot, how do I get the unwanted labels
off the pictures off?

The text in the top-left is the gallery title. To remove the gallery title, set  the following in the gallery's 'Pro Options' text area:

galleryTitlePosition="NONE"

The text near the bottom of the image is the caption area.
By default, WP-Juicebox uses the image filename (without the extension) as the image title. ("b-forgiving-1" in your screenshot.)
You can remove this by deselecting the 'Display Image Titles' checkbox (just above the 'Pro Options' text area).
You can remove the image number ("6/6" in your screenshot) by setting the following in the 'Pro Options' text area:

showImageNumber="FALSE"

You can remove the entire caption area (without needing to remove the image title and image number separately) by setting the following in the 'Pro Options' text area:

captionPosition="NONE"

For reference, a list of all Pro Options can be found here.

I hope this helps.

Re: very first publish fails on simple test page !!

well, this seemed promising. I did it all, but nothing changed.
I "saved".  Am I the only one who cannot do this? ???
The unwanted overlays appear on rollover like the little nav bar
draft:

Post's attachments

jb.jpg 116.67 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.