1

(1 replies, posted in Juicebox-Pro Support)

I'm not entirely sure what the problem is but here are 3 things that you can try.

(1) I notice that you are currently using Juicebox-Pro v1.4.3.2.
There have been 5 official releases since v1.4.3.2 (the current version being v1.5.1) with many bugfixes. Please see the Version History page for a full list of changes between versions.
I would recommend upgrading your Juicebox-Pro galleries to the current version to see if this helps with your problem.
Full instructions for downloading the latest version and upgrading existing galleries can be found on the Upgrading Juicebox support page.
(You can upgrade an existing gallery by simple swapping its current 'jbcore' folder with the 'jbcore' folder from the latest Juicebox-Pro download zip package ('juicebox_pro_1.5.1/web/jbcore').)

(2) I notice that your 'Urbano' gallery uses slightly different configuration options than your 'Paisajes' gallery (for example).
Try changing your 'Urbano' gallery's 'config.xml' file to make sure that it uses the same configuration options as your other 2 galleries. This might help.

(3) Your 'Urbano' gallery currently has both a galleryWidth of '100%' and a galleryHeight of '100%' (set in the gallery's embedding code) whereas your 'Paisajes' gallery (for example) has a galleryHeight of '100%' but a galleryHeight of '80%'.
Try changing your  'Urbano' gallery's galleryHeight to '80%', in line with your other 2 galleries, in case this makes a difference.
(If a gallery has both a galleryWidth of '100%' and a galleryHeight of '100%' but the gallery's parent containers do not have heights specified by CSS, then Juicebox might determine that the gallery takes up the entire web page (100% x 100%) and the gallery's layout may differ because of this.)

Hopefully these suggestions will help,
Please let me know how you get on and if I can be of any further assistance.

2

(11 replies, posted in Juicebox-Lite Support)

You're welcome!
I'm glad to hear that you've got everything working. Thank you very much for letting me know. It's most appreciated.

Incidentally, I've notified the developers of both issues above: the inability to view galleries locally in Firefox 68 and the strange problem regarding the use of ../ in the baseUrl (again, locally in Firefox).
I'm not sure what, if anything, can be done from within Juicebox to counter either of these issues (I expect nothing can be done with regard to the former) but at least bug reports have been filed and we have workarounds in the meantime.

3

(3 replies, posted in Juicebox-Pro Support)

You're welcome!
At least there is a workaround if you ever need to create a large gallery.
It's unfortunate but the problem seems to be a limitation of Adobe AIR with little that can be done from within JuiceboxBuilder-Pro's code to overcome it.
However, a bug report has been logged so, if anything can be done to improve the situation, at least the developers are aware of the issue.

4

(1 replies, posted in Juicebox-Pro Support)

Having a Juicebox gallery embedded on a web page should not disable Firefox's F5 reload-page functionality (and Juicebox-Pro does not have a configuration option to do this).
In fact, I've just loaded all 21 demo gallery pages (including embedded and full page galleries) from our demo overview page here and F5 reloads all pages without issue (Firefox 68.0.1, Windows 10 PC).
Try the demo galleries yourself to see if the problem in your browser is with all Juicebox gallery pages or just your own.
Maybe a fresh install (complete uninstal and reinstall) of Firefox will solve your problem.

5

(3 replies, posted in Juicebox-Pro Support)

There is no limit to the number of images that you can have in a gallery but you might not be able to add all the images to JuiceboxBuilder-Pro at once.

Unfortunately, if you try to add many images to JuiceboxBuilder-Pro at once, then Adobe AIR (the platform on which JuiceboxBuilder-Pro runs) may not be able to allocate enough memory for the task at hand. Even if your computer has plenty of free RAM, Adobe AIR applications are limited to around 1GB of memory allocation (as far as I am aware).
The workaround is to add your images in multiple smaller batches. Trial and error will help to determine a safe number of images per batch (it will depend on your own images). From your notes, it sounds like you should be able to add images in batches of 100 (or less). Try adding 100 images in your first batch and then the remainder of 78 images afterwards.

I hope that adding your images in a few separate actions instead of just one is not too much of an inconvenience although I realise that it is not ideal.

6

(6 replies, posted in Juicebox-Lite Support)

... that worked nicely...

Thank you for trying this. This suggests that incorrect paths or rewrite rules are not the cause of your problem.

Thank you also for reinstating your 'shumbatestgallery' gallery folder and for changing the embedding code in in your gallery's web page.
I have taken another look at your gallery's web page and see that the gallery is actually being embedded correctly.
It is just not visible because the gallery has a width of 100% but it is nested within a <td> element on your web page which has a width of 4px (so the gallery's actual width on your web page is 100% of 4px which is 4px).
If you want to continue using a gallery width of 100%, then you'll need to ensure that your gallery's parent containers all have widths (set via CSS) large enough to accommodate a gallery (much larger than 4px).
(I mentioned a similar problem above with heights as heights usually need to be defined whereas widths usually have a default value of 100%.)
Otherwise, if your table has a fixed width, then you might like to give your gallery a fixed width, too (although sorting out the dimensions of your table elements might be a better option, especially if your table is responsive and you want your gallery to be responsive, too).

Here are two possible solutions (which might require further tweaking depending on the layout of your page and the current dimensions of your gallery's parent containers).

#1 Give your gallery a fixed width
It looks like your gallery's parent <td> container currently has a width of 604px so try the following embedding code:

<!--START JUICEBOX EMBED-->
<script src="/shumbatestgallery/jbcore/juicebox.js"></script>
<script>
    new juicebox({
        baseUrl: "/shumbatestgallery/",
        containerId: "juicebox-container",
        galleryWidth: "604",
        galleryHeight: "600",
        backgroundColor: "rgba(34,34,34,)"
    });
</script>
<div id="juicebox-container"></div>
<!--END JUICEBOX EMBED-->

... or:

#2 Give the <table> that the gallery is nested within a width of 100% via CSS
Leave your gallery's width at 100% and add the following to the <head> ... </head> section of your gallery's web page:

<style>
    table {
        width: 100%;
    }
</style>

I hope this helps.

7

(6 replies, posted in Juicebox-Lite Support)

Thank you for trying my suggestion but I notice that the paths in your embedding code are incorrect.
I meant for you to try the exact code I posted above (rather than just adding a leading slash to your full https:// path).
Please try again using the code I posted above.

Incidentally, I notice that you seem to have removed your 'shumbatestgallery' gallery folder and have replaced it with a 'shumbatestgallery1' gallery folder which seems to an incomplete gallery folder (it does not contain a 'config.xml' file).

If reinstating your original 'shumbatestgallery' gallery folder and using the code from my previous post does not work, then please try the following.

(1) Create a sample gallery in JuiceboxBuilder-Pro and save it to a new empty folder named 'my_gallery'.
(2) Upload the entire 'my_gallery' folder to your root directory.
(3) Create a new HTML file in a plain text editor containing the code below and name it 'test_file.html'.

<!DOCTYPE html>
<html lang="en">
<head>
    <title>Juicebox-Pro Gallery</title>
    <meta charset="utf-8" />
    <meta name="viewport" id="jb-viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1, maximum-scale=1, user-scalable=0" />
    <style type="text/css">
    body {
        margin: 0px;
    }
    </style>
</head>
<body>
    <!--START JUICEBOX EMBED-->
    <script src="/my_gallery/jbcore/juicebox.js"></script>
    <script>
    new juicebox({
        baseUrl: "/my_gallery/",
        containerId: "juicebox-container",
        galleryWidth: "100%",
        galleryHeight: "100%",
        backgroundColor: "#222222"
    });
    </script>
    <div id="juicebox-container"></div>
    <!--END JUICEBOX EMBED-->
</body>
</html>

(4) Upload the 'test_file.html' file to your root directory (alongside your 'my_gallery' folder).
(5) You should now be able to view the gallery on its own web page by visiting https://www.ridgeback-douala.net/test_file.html

This should test the baseUrl functionality on your web server.

If this test scenario works, then something on your own gallery's embedding page may be causing the problem.
Load your own gallery's embedding page and check your browser's developer tools for JavaScript errors, custom CSS which might be hiding the gallery or HTML elements which might be obscuring the gallery.

If this test scenario does not work, then something on your web server may be causing the problem.
Check to see if you have an '.htaccess' file on your web server with any rewrite rules which might be interfering with the gallery files.

I hope this points you in the right direction.

You're welcome!
I'm glad it worked for you. Thanks for posting back to let me know.

I hope you have a good weekend, too!

9

(6 replies, posted in Juicebox-Lite Support)

I notice that you use absolute paths in your embedding code starting with http:// but you quote your website URL with an https:// link.

Try using relative paths in your embedding code starting with leading slashes (to denote your root directory).
This should work with both http:// and https:// (and also for accessing your domain with and without the www subdirectory).

Also, as you currently use a galleryHeight of 100%, this means that the gallery's actual height will be 100% of the height of the gallery's parent container so be sure to assign your gallery's parent container a height via CSS (otherwise Juicebox might not be able to determine what the gallery's actual height should be).
Try setting a galleryHeight of 600px, at least for testing purposes, to be sure that the gallery has valid dimensions and will be visible once the path problems have been ironed out.

Try the following:

<!--START JUICEBOX EMBED-->
<script src="/shumbatestgallery/jbcore/juicebox.js"></script>
<script>
    new juicebox({
        baseUrl: "/shumbatestgallery/",
        containerId: "juicebox-container",
        galleryWidth: "100%",
        galleryHeight: "600",
        backgroundColor: "rgba(34,34,34,)"
    });
</script>
<div id="juicebox-container"></div>
<!--END JUICEBOX EMBED-->

Hopefully this will help.
Please let me know how you get on. Thank you.

Unfortunately, very recently, Firefox 68.0 (released on 9 July 2019) introduced a new security restriction (very similar to the Safari 11 issue) which blocks the loading of Juicebox galleries locally (from your computer's hard drive). (As you have discovered, there is no problem once the gallery has been uploaded to a web server.)

Here is the relevant entry from the Firefox 68.0 Release Notes: https://www.mozilla.org/en-US/firefox/6 … easenotes/

Local files can no longer access other files in the same directory.

It's an unfortunate turn of events but, thankfully, not an insurmountable problem as there is a workaround.

Here are the steps required to relax this security restriction:
(1) Enter about:config in your Firefox browser's address bar.
(2) Click past the warning via the "I accept the risk!" button.
(3) Enter privacy.file_unique_origin in the search bar.
(4) Double-click the Preference Name to change the Value from 'true' to 'false'.

***Please do so at your own risk*** (although this should be no more of a risk than running the previous version of Firefox (67.0.4)).

This should allow you to, once again, view your galleries locally in Firefox.
I hope this helps.

Problem solved via email. (Full uninstallation/reinstallation solved problem.)

You're welcome!

Configuration options common to both Juicebox-Lite and Juicebox-Pro can be found in the 'Lite' section.

If you ever need to find out which section a configuration option is in, just search for the option name in the Config Options page and check which heading it comes under.

13

(12 replies, posted in Juicebox-Pro Support)

Problem resolved via email.

Solution was:
(1) Uninstall both JuiceboxBuilder-Pro and Adobe AIR
(2) Install an older version of Adobe AIR (v20.0)
(3) Install JuiceboxBuilder-Pro v1.5.1
(4) Upgrade Adobe AIR to current version (v32.0)

If anyone reading this thread encounters a similar issue and wants to try this solution, older versions of Adobe AIR can be downloaded from this archive page: https://helpx.adobe.com/air/kb/archived … rsion.html

14

(11 replies, posted in Juicebox-Lite Support)

Thank you for the update.
Looking back over your posts, I have now been able to replicate the problem myself.
The issue seems to be with using ../ in your baseUrl.
Firefox does not seem to like loading galleries locally (even after setting privacy.file_unique_origin to false) if you use ../ in your baseUrl to go back a level in your directory structure.
You can still use a relative baseUrl and view your galleries locally in Firefox but you would need to change your directory structure to do so, for example:

baseUrl="galleries/gallery001/",

The problem seems to specifically be with the use of ../ in the baseUrl. There seems to be no problem with using ../ in the path to the 'juicebox.js' file.
Oddly enough, you can view galleries which use ../ in the baseUrl locally in Edge (Windows) and most likely also in Safari (Mac) as long as you select 'Disable Local File Restrictions' from the 'Develop' menu first (details in this forum post).
I have notified the developers of this but there's probably very little that can be done from within Juicebox to affect core browser functionality.
At least, knowing the problem, you should be able to work around it (by changing your directory structure and ensuring that you do not need to go backwards to reach the gallery folder via the baseUrl).
I hope this helps.

15

(12 replies, posted in Juicebox-Pro Support)

Thanks for trying Safe Mode.
There seems to be some sort of incompatibility between JuiceboxBuilder-Pro and your computer as no-one else has ever reported the issue that you are facing before.
Unfortunately, I'm unable to replicate the problem myself which makes troubleshooting that much more difficult.
Please check your email. I have sent you a message.

To prevent the Open Image Button from appearing on the gallery's Button Bar, deselect the Show Open Button checkbox in JuiceboxBuilder-Pro's 'Customize -> Lite' section.

Otherwise, you can set showOpenButton="FALSE" as a configuration option (as an attribute to the opening <juiceboxgallery> tag) in your gallery's 'config.xml' file.

I hope this helps.

17

(12 replies, posted in Juicebox-Pro Support)

A web search for 'kernelbase.dll crash' returns many results (none for JuiceboxBuilder-Pro) but there does not seem to be an accepted solution for all scenarios and I think you've tried pretty much every suggestion I've come across and thought of.

One thing we've not tried yet, though...
Try booting into Safe Mode and running JuiceboxBuilder-Pro from there.
If it works OK in Safe Mode, then some other program or driver that is loaded and running in normal mode could be causing the crash.

Here's how to start your PC in Safe Mode in Windows 10:
https://support.microsoft.com/en-us/hel … -safe-mode

18

(11 replies, posted in Juicebox-Lite Support)

That's strange. If you did not have the latest version of Firefox (68.0) installed, then you should not have encountered the problem. The problem with viewing galleries locally in Firefox only started with Firefox 68.0 when they introduced the new security restriction.
Please try my suggestion anway and let me know how you get on. Thanks!

19

(12 replies, posted in Juicebox-Pro Support)

Unfortunately, previous versions are not available for download. (All download links always point to the latest version.)
However, I don't think reinstalling v1.5.0 would help.
As far as I am aware, there were no code changes between v1.5.0 and v1.5.1 which should have any bearing on the startup procedure.

Tried other adobe air applications, they work perfectly.

Have you tried JuiceboxBuilder-Lite yet? Does it crash on opening (like JuiceboxBuilder-Pro does) or does it run correctly (like the other AIR applications you have tried)?

As far as I can recall, no-one else has ever reported the problem that you are experiencing (with any version) so it seems to somehow be unique to your system.
I really don't know what is causing your problem and I've already suggested pretty much everything I can think of.

Maybe if we could find out how the JuiceboxBuilder-Pro.exe file ended up in your C:\Users\Liam\Documents\JuiceboxBuilder-Pro\ folder, we might have a clue as to the nature of your problem.

Out of interest, what are the current contents of your C:\Program Files (x86)\JuiceboxBuilder-Pro\ folder?
This folder should contain the following:

icons (folder)
META_INF (folder)
presets (folder)
template (folder)
jbBuilder-Pro.swf (file)
JuiceboxBuilder-Pro.exe (file)
mimetype (file)

Here are two more suggestions:

(1) Try running JuiceboxBuilder-Pro not from the desktop shortcut but, instead, by navigating to C:\Program Files (x86)\JuiceboxBuilder-Pro\ in Windows File Explorer and then right-clicking the JuiceboxBuilder-Pro.exe file and selecting 'Run as administrator'.

(2) As you are currently running Windows 10 version 1809 (build 17763.615), try upgrading to the current version (version 1903, build 18362.239). The kernelbase.dll file will be updated when you upgrade Windows 10 to version 1903 and this might help to resolve your problem.

Being that you are currently experiencing difficulties, I should perhaps point out that there are other methods of creating Juicebox galleries which do not require JuiceboxBuilder-Pro, many of which use plugins for other programs (such as Lightroom or Photoshop). If you use Lightroom or Photoshop, you might like to give them a try. Please see the Juicebox Plugins support page for details.

You can also create a gallery manually using the sample 'web' gallery (from the Juicebox-Pro download zip package) as a template. Instructions can be found here.

I'd certainly check the contents of the C:\Program Files (x86)\JuiceboxBuilder-Pro\ folder, run JuiceboxBuilder-Pro via the right-click 'Run as administrator' option and upgrade Windows 10 (to version 1903) as the next things to try.

20

(12 replies, posted in Juicebox-Pro Support)

Thanks for trying. I'm sorry that you're still having trouble.
Unfortunately, I'm running out of ideas.

Do you have any third-party security software installed and have you tried temporarily turning it off yet?

Try installing JuiceboxBuilder-Pro (from the free Juicebox-Lite zip package (you can download it from here). Does the same thing happen with JuiceboxBuilder-Lite?

The only other thing I can think of at the moment (and I don't really think it will help but you never know) is to reinstall Adobe AIR but instead of just double-clicking the AdobeAIRInstaller.exe installation file, right-click it and select 'Run as administrator'.

If all else fails, it might be worthwhile running Windows System File Checker (as the event log points towards kernelbase.dll, a system file), just to make sure that there are no corrupt system files.
Run an elevated command prompt (a command prompt with administrative rights) and enter sfc /scannow.
Please see this web page for further details: https://support.microsoft.com/en-us/hel … ted-system

Also, if you have an Adobe AIR log file in the following location, please take a look and see if there are any entries corresponding to JuiceboxBuilder-Pro crashes. (It might hold only information on installations but it's worth a look.)

C:\Users\Username\AppData\Local\Adobe\AIR\logs\Install.log

Edit:
I've just found this Adobe help page which seems to describe a similar problem to the one you reported. The help page refers to Photoshop instead of an AIR application but it sounds similar and hopefully it will help.

Photoshop CC crashes on launch and displays kernelbase.dll error as the faulting module in the Event Viewer.

Crash on launch | Kernelbase.dll error | Windows - https://helpx.adobe.com/photoshop/kb/ke … error.html

If the details in the web page apply to you (with regard to the graphics), then try the procedure but selecting Adobe AIR and JuiceboxBuilder-Pro instead of Photoshop.

21

(11 replies, posted in Juicebox-Lite Support)

Please double-check your version of Firefox and, assuming you are running Firefox 68.0 (the version which introduced the security restriction causing the problem), please try the instructions again.
The privacy.file_unique_origin preference does exist in my own Firefox 68.0 browser and the solution I posted worked for myself and another user in this forum thread.
Please also see the screenshot attached to this post which shows the privacy.file_unique_origin preference in the about:config section of my own Firefox browser.

22

(12 replies, posted in Juicebox-Pro Support)

Thank you for posting your event log.

Faulting application path: C:\Users\Liam\Documents\JuiceboxBuilder-Pro\JuiceboxBuilder-Pro.exe

I think line above might hold the key to the problem.
The JuiceboxBuilder-Pro.exe file should normally be in this location:

C:\Program Files (x86)\JuiceboxBuilder-Pro\JuiceboxBuilder-Pro.exe

All that is in my C:\Users\Username\Documents\JuiceboxBuilder-Pro\ folder is a 'presets' folder (as expected).
I do not know why your installation seems to have deposited the JuiceboxBuilder-Pro.exe file in your Documents folder but I reckon that's the reason why your JuiceboxBuilder-Pro is crashing.
If you have not already tried suggestion #3 from my post above (a complete reinstallation of JuiceboxBuilder-Pro), then please try it to see if it helps.
Another thing to try would be to create a new Administrator User Account on your PC, log into this new account and then install Adobe AIR and JuiceboxBuilder-Pro from there (in case a corrupt user profile is somehow contributing to your problem).
It might be a long shot but it should be fairly quick and easy to try and, in the absence of knowing exactly what is at the root of your problem, I would not rule anything out quite yet.

23

(12 replies, posted in Juicebox-Pro Support)

That's certainly very strange.
Here are a couple of things to try which might help to pinpoint the cause of your problem.

(1) Try completely disabling any third-party security software that you might have installed (e.g. Avast or AVG), including real-time protection and ransomware detection, before attempting to open JuiceboxBuilder-Pro to see if this might somehow be interfering with JuiceboxBuilder-Pro's functionality.
(Please do so at your own risk and be sure to disconnect from the internet first.)

(2) Check the exact time that the splash page disappears (JuiceboxBuilder-Pro crashes) and then take a look at the Windows Event Viewer to see if there are any entries in the 'Windows Logs -> Applications' or 'Windows Logs -> System' sections which coincide with the crash and give more information on the nature of your problem.
Please see this web page for more information on the Event Viewer: https://www.howtogeek.com/123646/htg-ex … an-use-it/

(3) Also, I'd try completely uninstalling and then reinstalling both JuiceboxBuilder-Pro and Adobe AIR following the procedure outlined in this forum post to see if this helps.

Hopefully these suggestions will help (or at least point you in the right direction.)

24

(11 replies, posted in Juicebox-Lite Support)

But when I try to view my website page locally in Firefox, it displays the following error message "Config file not found."

Unfortunately, very recently, Firefox 68.0 (released on 9 July 2019) introduced a new security restriction which blocks the loading of Juicebox galleries locally (from your computer's hard drive). (There is no problem once the gallery has been uploaded to a web server.)

Here is the relevant entry from the Firefox 68.0 Release Notes: https://www.mozilla.org/en-US/firefox/6 … easenotes/

Local files can no longer access other files in the same directory.

It's an unfortunate turn of events but, thankfully, not an insurmountable problem as there is a workaround.

Here are the steps required to relax this security restriction:
(1) Enter about:config in your Firefox browser's address bar.
(2) Click past the warning via the "I accept the risk!" button.
(3) Enter privacy.file_unique_origin in the search bar.
(4) Double-click the Preference Name to change the Value from 'true' to 'false'.

***Please do so at your own risk*** (although this should be no more of a risk than running the previous version of Firefox (67.0.4)).

I hope this helps.

25

(4 replies, posted in Juicebox-Pro Support)

First of all, I should note that the information contained in this thread is now out of date.
In Juicebox v1.3.0 (released 16 April 2013), thumbnail configuration options were changed to:
showThumbsButton (Lite & Pro)
showThumbsOnLoad (Pro only)
showSmallThumbsButton (Pro only)
showSmallThumbsOnLoad (Pro only)
(This is noted in the Version history page.)

showThumbsButton still applies to Juicebox-Lite as it did before (the option to display the Thumbnail Button on the gallery's Button Bar to allow the user to toggle the thumbnails on and off) but the only way to completely disable thumbnails is to use Juicebox-Pro and to set the following options:
showThumbsButton="FALSE"
showThumbsOnLoad="FALSE"
showSmallThumbsButton="FALSE"
showSmallThumbsOnLoad="FALSE"